AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present  

Go Back   AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present > AcuraLegend.Org > New Member Introductions

Reply
 
Thread Tools Display Modes
Old 01-23-2019, 03:17 PM   #1
adam73bgt
Junior Member
 
Join Date: Jan 2019
Location: UK
Posts: 6
adam73bgt is on a distinguished road
Default Hi from the UK

Hello!

Recently got myself a KA8 Honda Legend here in the UK, its a really tidy car but just has a couple electrical issues to sort out

Hoping they're going to be common issues with hopefully easy fixes
adam73bgt is offline   Reply With Quote
Old 01-24-2019, 07:24 AM   #2
JKLedbetter
Marcel's cousin
 
JKLedbetter's Avatar
 
Join Date: Jun 2009
Location: Trinity, AL
Posts: 742



JKLedbetter will become famous soon enough
Default

Welcome to the forum.

Describe the electrical issues and maybe we can help you sort them out.

-Kennon
JKLedbetter is offline   Reply With Quote
Old 01-24-2019, 10:29 AM   #3
adam73bgt
Junior Member
 
Join Date: Jan 2019
Location: UK
Posts: 6
adam73bgt is on a distinguished road
Default

Thanks!

Currently I've got:

A rear demister that doesn't demist
Heater fan only works on full speed (fan speed resistor?)
ABS light, seems to be code 1 ABS pump motor over run..
Aerial doesn't full retract, clicks at the end of travel each way
Drivers side electric windows are weird, the rear switch opens the front window, front switch doesn't work the front window, and the switch actually in the back doesn't work the drivers side rear window

I'll get a thread up with some photos when I get a chance
adam73bgt is offline   Reply With Quote
Old 01-25-2019, 12:08 PM   #4
JKLedbetter
Marcel's cousin
 
JKLedbetter's Avatar
 
Join Date: Jun 2009
Location: Trinity, AL
Posts: 742



JKLedbetter will become famous soon enough
Default

Quote:
Originally Posted by adam73bgt View Post
...Drivers side electric windows are weird, the rear switch opens the front window, front switch doesn't work the front window, and the switch actually in the back doesn't work the drivers side rear window...
Sort of sounds like the previous owner had the front switch go bad and just rewired it to the rear switch.

-Kennon
JKLedbetter is offline   Reply With Quote
Old 01-24-2019, 11:35 AM   #5
94LegendaryAcuraGS
The Mad Scientist!!
 
94LegendaryAcuraGS's Avatar
 
Join Date: Jul 2009
Location: Inside the LAB!! ;-)
Posts: 6,503


Real Name: DUH The Mad Scientist!! A.K.A. Chaka
94LegendaryAcuraGS has a spectacular aura about94LegendaryAcuraGS has a spectacular aura about
Default

Welcome to the fam!

The rear demister (defroster in the U.S.) likely has a break in one of the lines and are a little tedious to trace. I would check the connectors to the grid which unfortunately are hidden behind the rear c-pillar covers. Those covers are likely VERY fragile to try and pop off and inspect the connectors. Mine doesn't work on my KA8 and I have been nervous to try and do what I just said.

The resistor does sound like the culprit on the single speed for the heater fan.

The ABS light and issue I'll defer to someone with more experience commenting on. Those systems when they do fail are difficult to repair from what I understand. Alan Jackson may have a used one in working condition should you need a replacement.

The Aerial (sounds like the radio antenna in the U.S.) has a broken plastic mast and that is why you keep hearing the clicking sound and it doesn't completely retract. It can be fixed with ordering a new antenna mast. There are MULTIPLE vendors selling them here in the U.S. but ones I have used SEVERAL times in the past are these fellows. http://www.antennamastsrus.com/

As for the windows it sounds like an out of order main window switch. Those are a bit tough to find where all the features work (primarily the auto down for the driver's window). Alan Jackson may again be your best option to find a working one for a KA8 as they use a very different switch than a KA7 sedan.

We look forward to the pictures whenever you get a chance.
__________________
3.5 Type II Hybrid Club Member!
The Mad Scientist!!
94LegendaryAcuraGS is offline   Reply With Quote
Old 01-24-2019, 04:09 PM   #6
KA_Sammler
KA lover since 1991.
 
KA_Sammler's Avatar
 
Join Date: Jul 2013
Location: Germany
Posts: 1




Real Name: Ringo
KA_Sammler is on a distinguished road
Default

Quote:
Originally Posted by 94LegendaryAcuraGS View Post
As for the windows it sounds like an out of order main window switch. Those are a bit tough to find where all the features work (primarily the auto down for the driver's window). Alan Jackson may again be your best option to find a working one for a KA8 as they use a very different switch than a KA7 sedan.
Donīt forget, it is UK. RHD switch is mirrored to LHD.
__________________
You can not treat a car like a human being. A car needs love.
KA_Sammler is offline   Reply With Quote
Old 01-24-2019, 08:30 PM   #7
JKLedbetter
Marcel's cousin
 
JKLedbetter's Avatar
 
Join Date: Jun 2009
Location: Trinity, AL
Posts: 742



JKLedbetter will become famous soon enough
Default

Here's the section in the service manual for troubleshooting the Anti-Lock brake system:

http://service.arnach.net/index.php?...=723&z=2690&r=

It would be easier if you could get the special Bleeder T-Wrench, but beware, the one for the G2 (second generation Legend) is shorter than for the G1.

If the fluid level is correct the most likely cause of your code 1 is dirt in the solenoids allowing fluid to leak past. If so, you might be able to fix it simply by flushing fresh fluid through the system.

-Kennon
JKLedbetter is offline   Reply With Quote
Old 01-30-2019, 09:52 AM   #8
94LegendaryAcuraGS
The Mad Scientist!!
 
94LegendaryAcuraGS's Avatar
 
Join Date: Jul 2009
Location: Inside the LAB!! ;-)
Posts: 6,503


Real Name: DUH The Mad Scientist!! A.K.A. Chaka
94LegendaryAcuraGS has a spectacular aura about94LegendaryAcuraGS has a spectacular aura about
Default

Quote:
Originally Posted by KA_Sammler View Post
Donīt forget, it is UK. RHD switch is mirrored to LHD.
True and that'll make it even tougher to find. KA8 switches for left hand drive aren't easy to find in the states.

OP I saw what looked like your other posted thread. If you rebuild this and it works fantastic. If you can't I may have a connection or two to try and get a RHD version of the switch.
__________________
3.5 Type II Hybrid Club Member!
The Mad Scientist!!
94LegendaryAcuraGS is offline   Reply With Quote
Old 01-31-2019, 03:34 PM   #9
Midgez95KA7
"blu"Goofyowner
 
Midgez95KA7's Avatar
 
Join Date: Jun 2013
Location: Nashville, TN
Posts: 274

Real Name: "Midge"
Midgez95KA7 is on a distinguished road
Default

Welcome Adam in the UK!!! You've stop by the correct place sir.

If you happen to be on Facebook as well, there are a bunch of us Legend 'screwballs' on a page aptly named Acura Legend Owners & Enthusiasts if you so desire to check out another medium on the best model car(s) EVER built says all 24 of us left... LOL.
__________________
blu..."kickin'tail"
Midgez95KA7 is offline   Reply With Quote
Old 01-25-2019, 11:16 AM   #10
adam73bgt
Junior Member
 
Join Date: Jan 2019
Location: UK
Posts: 6
adam73bgt is on a distinguished road
Default

Thanks for the responses guys, just got the car back from having the timing belt done. The previous owner hadn't used the car much but the belt was getting old! I might get lucky with flushing through the brake fluid for the ABS issue as I imagine it hasn't been changed in years..

The Aerial/Antenna (sorry for English/US differences I do need to sort some 'tyres' for it soon haha) sounds like a pretty straightforward fix

Yes RHD indeed, they didn't sell a lot of Legends here, not many Coupes at all and not a huge amount of them survive still, so spare parts has been a bit interesting so far! Might have to see if I can repair the window switch or get lucky and find a car being broken for parts

I wonder if this photo will work..

http://img.retro-rides.org/i/v/adam7...a71f5f4baa.jpg
adam73bgt is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:24 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

AcuraLegend.Org is not affiliated with, nor represents in any form, Acura and Honda Motor Company. Some logos and names used herein remain the trademark of Honda Motor Company.