AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present  

Go Back   AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present > Marketplace > "Not Mine"

Closed Thread
 
Thread Tools Display Modes
Old 11-19-2009, 11:52 AM   #1
killaswa6
Member
 
Join Date: Sep 2009
Posts: 283
killaswa6 is on a distinguished road
Default Performance Chip

Has anyone used either of the following performance chips?

http://cgi.ebay.com/ebaymotors/2000-...item4a9b43f8cb


http://cgi.ebay.com/ebaymotors/PERFO...item2a02964a17


http://slrmotorsports.com/shop/index...uct_detail&p=3
killaswa6 is offline  
Closed Thread

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dinan Performance Chip? wonthuansoOp 2nd Gen. Legend Performance Enhancements 8 10-06-2009 08:19 PM
I need a chip, but which one? xpressive 2nd Gen. Legend Performance Enhancements 50 09-23-2009 09:27 AM
The baited hook about the best performance chip of 09' Telion 2nd Gen. Legend Performance Enhancements 80 08-03-2009 02:04 PM
Performance Chip Ablest31 2nd Gen. Legend Performance Enhancements 6 07-13-2009 10:07 AM
(2-28-08)Telion Type II Chip out performs Stock Type II chip in emissions Telion 2nd Gen. Legend General Discussion 3 06-09-2009 04:40 PM


All times are GMT -7. The time now is 05:36 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

AcuraLegend.Org is not affiliated with, nor represents in any form, Acura and Honda Motor Company. Some logos and names used herein remain the trademark of Honda Motor Company.