AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present  

Go Back   AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present > General DIY Discussions > The Projects > Non-Legend Builds

Reply
 
Thread Tools Display Modes
Old 12-05-2017, 02:55 PM   #61
l4zy415
FRISCO LEGEND BABY!!
 
l4zy415's Avatar
 
Join Date: Jun 2009
Location: Wichita, KS
Posts: 10,178

Real Name: James
l4zy415 has a spectacular aura aboutl4zy415 has a spectacular aura aboutl4zy415 has a spectacular aura about
Send a message via AIM to l4zy415 Send a message via MSN to l4zy415
Default

Always wondered what the status was on this build.
__________________


My Build Thread
Oh my gawd
That jar better blow me twice and cook breakfast for $1000.
l4zy415 is offline   Reply With Quote
Old 03-19-2019, 06:51 PM   #62
Quaraxkad
Moderator?
 
Quaraxkad's Avatar
 
Join Date: Jun 2009
Location: Port Orange, FL
Posts: 3,944


Quaraxkad is a glorious beacon of lightQuaraxkad is a glorious beacon of lightQuaraxkad is a glorious beacon of lightQuaraxkad is a glorious beacon of lightQuaraxkad is a glorious beacon of lightQuaraxkad is a glorious beacon of light
Send a message via AIM to Quaraxkad
Default

Hearing that this years NALM was going to be basically in my backyard got me motivated to get some work done. First step was finding someone to buy the scrap Legend, I've got someone coming to check it out and make me an offer in a few days. It had been parked dead in the garage right next to the Cutlass for quite some time. I pulled all the custom parts off of it and the rest is being scrapped. I'm keeping an eye out for another Legend though, it's still one of my favorite cars. I hooked up a battery, reinstalled the fusebox and ECU and it started right up like a champ. I just needed to back it out of the garage and roll up the windows. No exhaust, it was *loud*. Also, my dumb-ass forgot that the transmission cooler lines weren't hooked up to anything since I pulled the radiator. So, yeah, I leaked out all the transmission fluid in the garage and all the way down the recently bleached driveway, and was barely able to pull it back into the driveway (no trans fluid = no drive!).

Back to THIS project though. I still have the last engine I pulled from the junkyard. It's stripped down to the block and hanging out on a stand. I've already got ALL the gaskets required for a rebuild, but decided I didn't want to go through the trouble of rebuilding it, and I don't know of any machine shops or builders in the area to do it for me. So I went looking for a new complete unit I could just drop in.

So I bought another L67 engine today from an 04 Impala SS. 112K miles on it, compared to the ~200K (i think?) that are on the stripped block from a 2000 Grand Prix GTP. It's being pulled by the guys at the salvage yard some time in the next couple of days, they'll call me when it's ready and I'll go pick it up. Hopefully it's not too filthy, as we learned previously in this build I like things to be clean, but give up when it takes too long TO clean.

It's been so long since I've worked on or thought about this that I've forgotten a whole lot of what needs to be done. I *think* I have most of the parts already. The biggest hurdle I can recall is the wiring harness. I need to re-pin 75% of the wires on the firewall C100 connector. That's one of the things that I got stuck on previously. The documentation for wiring in this swap is virtually non-existent, and on top of that I've found some wire color discrepancies between the factory manual wiring diagrams and my harness.

That's the news for today. I really think this time I'm going to remain motivated for long enough to get this done! I'm super excited to finally get this car back on the road.

Last edited by Quaraxkad; 03-25-2019 at 11:21 PM.
Quaraxkad is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Quaraxkad's problem... rwheadon The Water Cooler 25 12-30-2011 07:50 PM


All times are GMT -7. The time now is 10:40 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

AcuraLegend.Org is not affiliated with, nor represents in any form, Acura and Honda Motor Company. Some logos and names used herein remain the trademark of Honda Motor Company.