AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present  

Go Back   AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present > Second Generation Legend -- 1991 - 1995 > 2nd Gen. Legend General Discussion

Reply
 
Thread Tools Display Modes
Old 07-03-2012, 08:10 AM   #21
abathur
Junior Member
 
Join Date: Jun 2012
Posts: 5
abathur is on a distinguished road
Default

EGR done (yes, it was completely clogged!), sparkplugs done, and after the mess I got myself into with the o2 sensors, I wish I hadn't already placed the order when Matt wrote back on them (or that I'd just paid to ship them back..., anyways).

Went to re-attempt inspection this morning and passed nox but failed HC with 209 of 114 allowed and CO with 5.91 of 0.63 allowed. Full test results below. Thoughts?

Quote:
Test 1:
15mph:
HC: 51 of 117
CO: .07 of .65
CO2: 14.9 of N/A
O2: .1 of N/A
Nox: 866 of 879
Dilution: 14.97 of >6.0

25mph:
HC: 33 of 114
CO: .04 of .63
CO2: 15.0 of N/A
O2: .1 of N/A
Nox: 1195 of 796 (FAIL)
Dilution: 15.04 of >6.0
Quote:
Test 2:
15mph:
HC: 34 of 117
CO: .03 of .65
CO2: 14.7 of N/A
O2: .1 of N/A
Nox: 294 of 879
Dilution: 14.73 of >6.0

25mph:
HC: 209 of 114 (FAIL)
CO: 5.91 of .63 (FAIL)
CO2: 11.1 of N/A
O2: .1 of N/A
Nox: 557 of 796
Dilution: 17.01 of >6.0

Last edited by abathur; 07-03-2012 at 08:35 AM. Reason: adding full test results
abathur is offline   Reply With Quote
Old 07-03-2012, 12:16 PM   #22
ari_one
MeltingInTheSun
 
ari_one's Avatar
 
Join Date: Jun 2009
Location: Phoenix
Posts: 2,182

ari_one will become famous soon enough
Default

Quote:
Just for reference info, when I failed emissions for CO not NOX my first attempted fix was cleaning EGR tube and replacing spark plugs. The result was my NOX went from 2.3 to 1.42 (Arizona test) but my CO went up The final result was that I changed the O2 sensors and my CO went from 15.64 to 8.86 easily passing and my NOX went from the 1.42 to 0.64 (just for reference).
Initial:
HC 00.66
CO 13.51
NOX 02.30

Cleaned EGR and new plugs:
HC 00.76 (up)
CO 15.64 (up)
NOX 01.42 (down)

Replaced O2 sensors:
HC 00.67 (down)
CO 08.86 (down)
NOX 00.64 (down)

The AZ emission is different in that the car gets "driven" through a variable speed course. Otherwise the question as always is was the car "hot", meaning did you drive it at highways speeds for at least 20 minutes before the test?
__________________
Parting out 4 91 L Sedans (mostly type 'F', some type 'E') and 93 Coupe type 'E':
https://docs.google.com/spreadsheets...it?usp=sharing

ari_one is offline   Reply With Quote
Old 07-11-2012, 01:38 PM   #23
Canadian144
Senior Member
 
Canadian144's Avatar
 
Join Date: May 2011
Location: Toronto / Boston
Posts: 1,093

Real Name: Ryan
Canadian144 will become famous soon enough
Default

Crap! Went for my emissions test today. I passed everything but NOx, which is done on the dyno at a certain RPM. limit was 408, I had a 639.

Conditions - I had been driving the car for at least an hour, most of it highway. I have been running ONLY 91 in the tank. Prior to the test, I had ran Lucas oil fuel system cleaner , STP fuel injector cleaner, and STP fuel system cleaner through. I still occasionally had this bad smell (not rotten eggs though, just a weird gassy smell).

I pulled an intake manifold and EGR pipe from one of my parts engines, took it apart, and cleaned it all up. Friday, $250 of new IM gaskets + o-rings for injectors are coming to my local Acura dealer, and then I'll have to swap IMs and get the car re-tested the same day, as my temp stickers expire Friday.

My O2 sensors seem fine, cat seems OK, so EGR seems to be the only plausible idea after some research. EGR is not throwing a code, neither is the O2 sensors. I imagine my EGR valve itself is fine, just the pipe and IM is clogged.

Friday is going to be a LONG day.
__________________
92 Legend coupe / 92 Integra GS-R / 09 STI
Canadian144 is offline   Reply With Quote
Old 07-15-2012, 08:02 AM   #24
Canadian144
Senior Member
 
Canadian144's Avatar
 
Join Date: May 2011
Location: Toronto / Boston
Posts: 1,093

Real Name: Ryan
Canadian144 will become famous soon enough
Default

Passed! EGR makes a HUGE difference. My pipe actually ended up not being that clogged (just slightly) but replacing the intake manifold with a 100% clean one and with a 100% clean EGR pipe got me to pass. The car is still running rich though, so I was exactly on the line for HC ppm. Need to check my injectors.

Before:
Idle test
HCppm: 49/200 (pass)
CO %: 0.09/1.00 (pass)

1700rpm test:
HCppm: 26/55 (pass)
CO%: 0.06/0.31 (pass)
NO ppm: 639/308 (fail)

After:
Idle test
HCppm: 120/200 (pass, but went up!)
CO %: 0.36/1.00 (pass, but went up!)

1700rpm test:
HCppm: 55/55 (pass, but barely)
CO%: 0.22/0.31 (pass)
NO ppm: 146/308 (pass)

Just happy to finally have the car permanently on the road.

The guys doing the test at Canadian Tire (it's hard to explain what this place is to Americans... you have to visit hahaha) were loving my Legend lol. The mechanic called 2 other guys over to look at my engine when they popped the hood, as well as the service advisor working at the desk. After they did the test the mechanic told me it was the meanest sounding Acura he'd ever heard! Service advisor also told me it was in better shape then any Acura they usually deal with.
__________________
92 Legend coupe / 92 Integra GS-R / 09 STI
Canadian144 is offline   Reply With Quote
Reply

Bookmarks

Tags
egr, emissions, nox


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cleaning 02 sensors failed Conrad 2nd Gen. Legend General Discussion 10 08-21-2011 09:43 PM
Acura legend crash test ( g2 ) Tippey The Water Cooler 12 06-01-2011 11:21 AM
My Legend Failed Me LegendaryAffinity 1st Gen. Legend General Discussion 18 11-26-2010 10:52 PM
Failed state emissions test Tm1 1st Gen. Legend General Discussion 6 10-24-2010 06:51 AM
FAILED emissions due to NO SickSUN71 2nd Gen. Legend General Discussion 9 01-03-2010 06:48 PM


All times are GMT -7. The time now is 07:23 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.

AcuraLegend.Org is not affiliated with, nor represents in any form, Acura and Honda Motor Company. Some logos and names used herein remain the trademark of Honda Motor Company.