AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present  

Go Back   AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present > First Generation Legend -- 1986 - 1990 > 1st Gen. Legend General Discussion

Reply
 
Thread Tools Display Modes
Old 04-28-2022, 12:43 PM   #1
Beeze
O.G. in O.C.
 
Beeze's Avatar
 
Join Date: Jun 2009
Location: Socal
Posts: 243

Real Name: Brent
Beeze is on a distinguished road
Unhappy Engine died on Freeway

I was driving my 90LS MT Sedan on the freeway yesterday after it had sat for a while. When suddenly I heard a "pop whoosh" sound from the passenger side engine bay and the engine died, I lost power steering and braking. Once I got the car pulled over, I tried cranking it but I was not getting any compression, so it would not start. I had it towed home and there is a serious oil leak from the passenger side. I checked and all the belts are intact. Any ideas or troubleshooting suggestions?

Last edited by Beeze; 04-28-2022 at 01:00 PM.
Beeze is offline   Reply With Quote
Old 04-28-2022, 07:04 PM   #2
JKLedbetter
Marcel's cousin
 
JKLedbetter's Avatar
 
Join Date: Jun 2009
Location: Trinity, AL
Posts: 814



JKLedbetter will become famous soon enough
Default

This sounds very bad.

Broken timing belt bent the valves bad.

Or rod through the block bad.

What symptoms led you to conclude you were not getting any compression?

You lost power steering and power braking simply because the engine died.

As for troubleshooting, first check the timing belt for breakage or slippage.

Look for a hole in the block in the vicinity of the oil leak.

-Kennon
JKLedbetter is offline   Reply With Quote
Old 06-20-2022, 05:43 AM   #3
JKLedbetter
Marcel's cousin
 
JKLedbetter's Avatar
 
Join Date: Jun 2009
Location: Trinity, AL
Posts: 814



JKLedbetter will become famous soon enough
Default

Any update???
JKLedbetter is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Car died need help 94l 2nd Gen. Legend General Discussion 15 12-16-2015 05:54 PM
Help please! My car died :( 93type2 2nd Gen. Legend General Discussion 2 04-06-2011 12:08 PM
my coupe hesitating on freeway???? BABO_C27A1 1st Gen. Legend General Discussion 12 03-19-2010 11:24 PM
Engine died houston90legend 1st Gen. Legend General Discussion 20 11-30-2009 03:57 PM
Tire popped on freeway and pulled out wire harness in my lude! filmshoot The Water Cooler 9 08-04-2009 03:06 PM


All times are GMT -7. The time now is 03:43 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.

AcuraLegend.Org is not affiliated with, nor represents in any form, Acura and Honda Motor Company. Some logos and names used herein remain the trademark of Honda Motor Company.