AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present  

Go Back   AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present > First Generation Legend -- 1986 - 1990 > 1st Gen. Legend General Discussion

Reply
 
Thread Tools Display Modes
Old 04-25-2019, 06:30 PM   #1
vsouvann
Junior Member
 
Join Date: Sep 2017
Location: San Diego
Posts: 16

Real Name: Vin
vsouvann is on a distinguished road
Default High and Rough idle (unstable) HELP!!!

I live in San Diego. I took my 1987 Legend Sedan to get Smog Tested, but the tech guy said that it wouldn't pass because the idle was rough and too high, around 1500 RPM. He said that it's gotta be under 1000 RPM. I tried adjusting the throttle cable and played with the flat screw by the intake unit with No Luck. When the engine warms up, it starts to bounce up and down.
Any advice is much appreciated, thanks.
vsouvann is offline   Reply With Quote
Old 04-25-2019, 07:08 PM   #2
JKLedbetter
Marcel's cousin
 
JKLedbetter's Avatar
 
Join Date: Jun 2009
Location: Trinity, AL
Posts: 741



JKLedbetter will become famous soon enough
Default

The first thing to check is the coolant temp sensor.

Here's a thread about it:

http://forums.acuralegend.org/high-i...8.html?t=27968

-Kennon
JKLedbetter is offline   Reply With Quote
Old 04-25-2019, 08:01 PM   #3
vsouvann
Junior Member
 
Join Date: Sep 2017
Location: San Diego
Posts: 16

Real Name: Vin
vsouvann is on a distinguished road
Default

Thanks,
I was reading the thread earlier, but where exactly is the water coolant sensor? I will get a new one and replace it.
vsouvann is offline   Reply With Quote
Old 04-25-2019, 08:08 PM   #4
vsouvann
Junior Member
 
Join Date: Sep 2017
Location: San Diego
Posts: 16

Real Name: Vin
vsouvann is on a distinguished road
Default

I think I just found it. Is it under the distributor cap?
I also read something about the FIV. How do I check to see if that's good or bad?

Last edited by vsouvann; 04-25-2019 at 08:22 PM.
vsouvann is offline   Reply With Quote
Old 05-04-2019, 02:33 PM   #5
vsouvann
Junior Member
 
Join Date: Sep 2017
Location: San Diego
Posts: 16

Real Name: Vin
vsouvann is on a distinguished road
Default

Thanks for your help JKLedbetter. I finally got it done.
vsouvann is offline   Reply With Quote
Old 05-05-2019, 07:39 AM   #6
stephen
Senior Member
 
Join Date: Aug 2009
Location: Sacramento, CA
Posts: 1,010
stephen is on a distinguished road
Default

The problem you have usually comes from the fast idle valve (Honda part number 16500-PL2-901 no longer available). It's a vacuum bleed that is controlled by coolant temperature.
Commonly all that is needed is to bleed the cooling system.

I think Eric the Car Guy has a video on this.
stephen is offline   Reply With Quote
Old 05-05-2019, 08:02 AM   #7
stephen
Senior Member
 
Join Date: Aug 2009
Location: Sacramento, CA
Posts: 1,010
stephen is on a distinguished road
Default

This is the Eric the Car Guy video

https://www.youtube.com/watch?v=L788jKEVblY
stephen is offline   Reply With Quote
Old 05-09-2019, 08:53 AM   #8
stephen
Senior Member
 
Join Date: Aug 2009
Location: Sacramento, CA
Posts: 1,010
stephen is on a distinguished road
Default

So what was the fix?
stephen is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Occasional rough idle Patmka8 2nd Gen. Legend General Discussion 2 11-02-2014 03:22 PM
Idle unstable Peabodyn 1st Gen. Legend General Discussion 9 07-20-2014 01:38 PM
rough idle but only in drive Al Taylor 1st Gen. Legend General Discussion 8 03-11-2013 11:23 AM
Rough idle stall fslaugts 1st Gen. Legend General Discussion 9 10-21-2012 10:07 PM
Rough idle symptoms NorCaLegend 2nd Gen. Legend General Discussion 40 01-15-2011 08:28 PM


All times are GMT -7. The time now is 04:33 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

AcuraLegend.Org is not affiliated with, nor represents in any form, Acura and Honda Motor Company. Some logos and names used herein remain the trademark of Honda Motor Company.