AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present  

Go Back   AcuraLegend.Org - The Acura Legend Forum for All Generations of the Honda / Acura Legend; 1986 to Present > First Generation RL (Third Generation Legend) -- 1996 - 2004 > 1st Gen. RL General Discussion

Reply
 
Thread Tools Display Modes
Old 02-02-2016, 08:11 AM   #1
VladislavHonda
Junior Member
 
Join Date: Apr 2015
Posts: 4
VladislavHonda is on a distinguished road
Default odometr. help!

Unlit window of the odometer on the dashboard. Has anyone solved this problem?
VladislavHonda is offline   Reply With Quote
Old 01-20-2021, 11:53 AM   #2
00RL
Junior Member
 
Join Date: Jan 2021
Posts: 2

00RL is on a distinguished road
Default

There is one way to fix this issue, this was my experience with my 2000 RL in 2017 (copied from another forum and pasted here.) It depends on what you can live with, how much aggravation you can handle and how much your willing to spend.

Long story! Just got my RL back from the dealer after 10 days with my odometer functioning. I took my car to the Acura dealer last December to have the timing belt, water pump, and radiator hoses replaced and to have them troubleshoot my odometer which had been dead for about 2 1/2 months. The tech said it was the bulbs for the unit that were bad. I ordered the bulbs for the whole cluster ($371.00) and was going to have the tech install them but he had reservations about taking the dash apart and possibly damaging the trim piece around the radio and climate controls. The reason he had reservations is the OEM piece costs over $1200.00, and he didn't even think he could get one. I told him to wait and I would research getting a back-up trim piece before he tries to fix it. I found a trim piece on eBay and told him I would bring the car back in July or August, 2017 to have the bulbs installed which is what I did. The end of the first day I get a call that the bulbs didn't fix the problem and that it need the odometer, trip-meter print ($411.00) to fix it. The end of day two I get a call that the that part didn't fix it and "oh-by-the-way" the tech inadvertently broke the instrument cluster glass. At this point the tech says it's most likely the circuit board that runs the whole length of the dashboard and depending on what reference you use it runs anywhere from $612.00 to over $900.00. At this point with me having spent over $780.00 they decide to buy me a used instrument cluster and ship it with my old cluster to a company in California that is authorized to download the milage information from the chip on my old cluster and upload onto the replacement cluster's chip. The cluster came back Friday the 18th and on Saturday the 19th after they install the new bulbs, odometer, trip-meter board and the new glass on my used instrument cluster I pick my car up on the 19th with 106,403 miles displayed along the the outside air temperature. I'm a happy-camper at this point until I get in to drive away and notice the SRS light is on, and the first thing that comes to mind is the seat belt buckle the dealer replaced last year under warranty. The tech comes back with his laptop and runs a diagnostic resets the light when I asked him why he didn't notice it before he said that he thought my car came in with the SRS light on I said I wouldn't drive with an SRS lite because it disables the airbag system but he said a lot of people do because of the related costs of replacing parts in the system. My guess is the light was set by the system of the car the instrument cluster came from because it cleared no problem and has not come back. This is why I didn't attempt to fix this gripe myself and was willing to eat the cost of parts and the dealer's hourly labor charge to get this problem fixed. As it turns out it only cost me the price of the bulbs and the circuit board and they ate the the cost of the new glass, the used instrument cluster, shipping costs to and from California and the labor cost for putting it all back together. I feel fortunate that this worked out the way it did since the original estimate for new bulbs and the two hours labor to install was $621.37 which is high but a car without a functioning odometer is unacceptable to me. These are the issues that come with owning older vehicles and in the long run it's worth it to me.
00RL is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -7. The time now is 04:33 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.

AcuraLegend.Org is not affiliated with, nor represents in any form, Acura and Honda Motor Company. Some logos and names used herein remain the trademark of Honda Motor Company.